Python 2 ya no es compatible con la comunidad. Te recomendamos que migres las apps de Python 2 a Python 3.

Configura el entorno de desarrollo

Para configurar tu entorno de desarrollo en Python 2, debes hacer lo siguiente:

  1. Descarga y, luego, instala la versión más reciente de Python 2.

    Consulta Entorno de ejecución de Python 2 para obtener una lista de las versiones compatibles.

  2. Descarga, instala y, luego, inicializa el SDK de Cloud. Si ya instalaste el SDK de Cloud, ejecuta el comando de gcloud components update para actualizarlo a la versión más reciente.

    El SDK de Cloud te proporciona las herramientas de línea de comandos de gcloud para implementar y administrar tus apps.

    Luego de descargarlo, debes aceptar los Términos que rigen el uso del SDK de Cloud para App Engine.

    Descargar el SDK de Cloud para su instalación

  3. Ejecuta el comando siguiente en tu terminal a fin de instalar el componente de gcloud, que incluye la extensión de App Engine para Python 2:

     gcloud components install app-engine-python
    

Instala herramientas opcionales

  • Instala Git para acceder a códigos, muestras, bibliotecas y herramientas en GitHub:

    Descargar e instalar Git

  • Instala tus herramientas o framework preferidos; por ejemplo, puedes usar cualquiera de los siguientes frameworks para desarrollar tu app Python 2:

  • Ejecuta el siguiente comando a fin de instalar el componente Extra Libraries para Python 2, que incluye las bibliotecas graphy y Django:

      gcloud components install app-engine-python-extras
    

Instala la compatibilidad con appcfg

Si ya usaste el SDK original de App Engine y necesitas seguir usando el comando appcfg obsoleto, puedes descargar y, luego, instalar el SDK original de App Engine; para esto, sigue las instrucciones que se indican a continuación: El SDK de Cloud no incluye el comando appcfg.