Como a versão 5.5 do PHP não é mais compatível com a comunidade, recomendamos que novos aplicativos usem o ambiente de execução do PHP 7.

Documentação do ambiente padrão do PHP 5 no Google App Engine

O ambiente padrão do PHP 5 para App Engine facilita a criação e a implantação de um aplicativo que será executado de maneira confiável, sob grande carga e com grandes quantidades de dados. O aplicativo é executado no próprio ambiente seguro e confiável, independente do hardware, sistema operacional ou local físico do servidor.