Como a versão 5.5 do PHP não é mais compatível com a comunidade, recomendamos que novos aplicativos usem o ambiente de execução do PHP 7.

Configurar o ambiente para desenvolvedores

Para configurar seu ambiente de desenvolvimento em PHP 5:

  1. Faça o download e instale a versão mais recente do PHP 5.

    Consulte Ambiente de execução do PHP 5 para uma lista das versões compatíveis.

  2. Faça o download, instale e inicialize o SDK do Cloud: Se você já tiver o SDK do Cloud instalado, execute o comando gcloud components update a fim de atualizar para a versão mais recente.

    O SDK do Cloud fornece a ferramenta de linha de comando gcloud para implantar e gerenciar aplicativos.

    Ao fazer o download, você concorda com os Termos que regem o uso do SDK no App Engine.

    Faça o download e a instalação do SDK do Cloud

Como instalar ferramentas opcionais

Como instalar o suporte para appcfg

Caso você já tenha usado o SDK do App Engine original e precise continuar a usar o comando appcfg obsoleto, será possível fazer o download e instalar o SDK do App Engine original seguindo as instruções abaixo. O SDK do Cloud não inclui o comando appcfg.