PHP バージョン 5.5 はコミュニティでサポートを終了したため、新しいアプリでは PHP 7 ランタイムを使用することを強くおすすめします。

開発環境の設定

PHP 5 で開発するための環境を設定するには:

  1. PHP 5 の最新リリースをダウンロードしてインストールします。

    サポートされているバージョンのリストについては、PHP 5 ランタイム環境をご覧ください。

  2. Cloud SDK をダウンロードしてインストールし、初期化します。すでに Cloud SDK がインストールされている場合は、gcloud components update コマンドを実行して最新のリリースに更新します。

    Cloud SDK には、アプリのデプロイと管理に使用できる gcloud コマンドライン ツールが用意されています。

    Cloud SDK for App Engine をダウンロードすることで、Cloud SDK for App Engine の使用を規定する利用規約の各条項に従うことに同意したとみなされます。

    Cloud SDK をダウンロードしてインストール

オプション ツールのインストール

appcfg のサポートのインストール

以前に元の App Engine SDK を使用していて、非推奨の appcfg コマンドを引き続き使用する必要がある場合は、代わりに次の手順で元の App Engine SDK をダウンロードしてインストールできます。Cloud SDK には appcfg コマンドは含まれていません