PHP バージョン 5.5 はコミュニティでサポートを終了したため、新しいアプリでは PHP 7 ランタイムを使用することを強くおすすめします。

Cloud SDK への移行

スタンドアロンの App Engine SDK は 2019 年 7 月 30 日をもって非推奨となっており、2020 年 8 月 30 日以降はダウンロードできません。次の表は、非推奨になる機能と推奨される代替策の一覧です。

非推奨 推奨される対処方法
スタンドアロンの App Engine SDK Cloud SDK をダウンロードします。
appcfg コマンド AppCfg から gcloud コマンドラインに移行します。

移行スケジュール

2019 年 7 月 30 日: スタンドアロンの App Engine SDK をベースとしたツールが非推奨になりました。

2020 年 8 月 30 日: スタンドアロンの App Engine SDK をダウンロードできなくなります。スタンドアロンの App Engine SDK を使用している場合、動作しなくなる可能性があります。

2020 年 8 月 30 日: Google がスタンドアロンの App Engine SDK を停止し、サポートを終了しました。

下位互換性のない機能

appcfg ツールとスタンドアロンの App Engine SDK が非推奨になることから、現在、次の機能は Cloud SDK でサポートされていません。