Part 2: Runtime quickstart

Supported platforms

You can install hybrid runtime on the following platforms:

Platform Version
Google Kubernetes Engine (GKE) Version 1.15.x
Anthos (GKE on-prem) Version 1.3.x, 1.4.x, or 1.5.x
Azure Kubernetes Service (AKS)
(using Anthos attached clusters)
Version 1.17.x
Amazon EKS
(using Anthos attached clusters)
Version 1.16.13
GKE on AWS
Anthos version 1.4.x or 1.5.x

Minimum cluster configurations

Your cluster must meet minimum configuration requirements. For details, see Minimum cluster configurations.

Prerequisites

This section describes tasks you must accomplish before you begin the runtime plane quickstart install.

Complete the following tasks to ensure that you can successfully begin the runtime installation (as described in this section):

After you have satisfied the above prerequisites, go to the quickstart for your platform:

GKE Quickstart GKE on-prem Quickstart AKS Quickstart EKS Quickstart GKE on AWS Quickstart