Version 1.0. Diese Version wird nicht mehr unterstützt, wie in der Supportrichtlinie für Anthos-Versionen beschrieben. Führen Sie ein Upgrade auf eine unterstützte Version durch, um die neuesten Patches und Updates für Sicherheitslücken, Kontakte und Probleme bei Anthos-Clustern in VMware (GKE On-Prem) zu erhalten. Die neueste Version finden Sie hier.

Versionsverlauf

Auf dieser Seite wird die GKE On-Prem-Versionsverwaltung erläutert.

Versionierungsschema

Die GKE On-Prem-Version hat das Format XYZ-gke.N.

Hauptversion (X)
Hauptversionen führen zu abwärtskompatiblen Änderungen.
Nebenversionen (X.Y)
Nebenversionen stellen in der Regel neue Funktionen bereit.
Patchversionen (X.Y.Z-gke.N)
Patchversionen sind in der Regel klein und enthalten Korrekturen und Sicherheitsupdates. Neue Funktionen werden nicht allgemein eingeführt. -gke.N ist die Versionsnummer der Version.

GKE On-Prem-Versionen

Die folgenden GKE On-Prem-Versionen werden vollständig unterstützt und bieten die neuesten Patches und Updates für Sicherheitslücken, Kontakte und Probleme, die GKE On-Prem betreffen. Weitere Informationen finden Sie in den Versionshinweisen.

VersionReleasedatumDownloadsDokumentation
1.7.0-gke.16 25. März 2021 1.7 Downloads 1.7 Dokumentationen
1.6.2-gke.0 26. Februar 2021 1.6 Downloads 1.6 Dokumentation
1.6.1-gke.1 27. Januar 2021 1.6 Downloads 1.6 Dokumentation
1.6.0-gke.7 10. Dezember 2020 1.6 Downloads 1.6 Dokumentation
1.5.3-gke.0 21. Januar 2021 1.5 Downloads 1.5 Dokumentation
1.5.2-gke.3 16. November 2020 1.5 Downloads 1.5 Dokumentation
1.5.1-gke.8 23. Oktober 2020 1.5 Downloads 1.5 Dokumentation
1.5.0-gke.27 24. September 2020 1.5 Downloads 1.5 Dokumentation

Kubernetes- und Knoten-Kernel-Versionen

Die folgende Tabelle zeigt für jede GKE On-Prem-Version die Kubernetes-Version und die Linux-Kernel-Version für die Clusterknoten an:

GKE On-Prem-Version Kubernetes-Version Knoten-Kernel-Version
1.7.0 1.19.7 5.4.0.1010.11 (ubuntu), 5.4.92 (cos)
1.6.2 1.18.13 5.4.0.1009.10
1.6.1 1.18.13 5.4.0.1007.8
1.6.0 1.18.6 5.4.0.1004.5
1.5.3 1.17.9 5.4.0.1007.8
1.5.2 1.17.9 5.4.0.47.51
1.5.1 1.17.9 5.4.0.47.51
1.5.0 1.17.9 5.4.0.47.51

Versionsverwaltete Entitäten

Jeder GKE On-Prem-Release enthält die folgenden versionsverwalteten Entitäten:

Entity Beschreibung
gkeadm Das Befehlszeilentool zum Erstellen und Verwalten von Administrator-Workstations. Führen Sie den Befehl gkeadm version aus, um die Version zu ermitteln.
OVA der Administrator-Workstation

Öffnen Sie die virtuelle Appliance (OVA) für die Administrator-Workstation. Enthält das Betriebssystem-Image für die Administrator-Workstation sowie das Cluster-Bundle und das gkectl-Befehlszeilentool.

Die Versionsnummer ist Teil des Dateinamens, zum Beispiel:


gke-on-prem-admin-appliance-vsphere-1.6.1-gke.1.ova

Weitere Informationen finden Sie in der PDF-Datei „Open Virtualization Format Specification”

gkectl Die Befehlszeile für GKE On-Prem. Cluster erstellen und verwalten, Konfigurationsdateien erstellen und Preflight-Prüfungen ausführen. In der Administrator-Workstation-OVA-Datei enthalten. Führen Sie zum Überprüfen der Version gkectl version aus.
Clusterset

Ein Archiv, das Clusterkomponenten und das Betriebssystem-Image für Clusterknoten enthält. In der Administrator-Workstation-OVA-Datei enthalten.

Die Versionsnummer ist Teil des Dateinamens, zum Beispiel:


gke-onprem-vsphere-1.6.1-gke.1.tgz

Sicherheitsupdates

Informationen dazu, ob ein Upgrade Sicherheitsupdates enthält, finden Sie unter Versionshinweise und in den Sicherheitsbulletins von Google Kubernetes Engine (GKE).

Versionskompatibilität

Virtualisierungsschicht

1,7 1,6 1.5 1.4
Version

vSphere 6.5U3 oder höher

vSphere 6.7U3 oder höher

vSphere 7.0

vSphere 6.5U3 oder höher

vSphere 6.7U3 oder höher

vSphere 6.5U3 oder höher

vSphere 6.7U3 oder höher

vSphere 6.5U3 oder höher

vSphere 6.7U3 oder höher

Edition vSphere Standard * oder höher vSphere Standard * oder höher vSphere Standard * oder höher vSphere Standard * oder höher

Netzwerkoptionen

1,7 1,6 1.5 1.4
vSphere-Standard-Switch Ja Ja Ja Ja
Verteilter vSphere-Switch Ja Ja Ja Ja
vSphere NSX-T Ja ‡ Ja ‡ Ja ‡ Ja ‡

Load-Balancing-Optionen

1,7 1,6 1.5 1.4
F5 BIG-IP #

F5 Big-IP Controller v1.14.0

Kompatibel mit BIG-IP v12.x-v15.x

F5 Big-IP Controller v1.14.0

Kompatibel mit BIG-IP v12.x-v15.x

F5 Big-IP Controller v1.14.0

Kompatibel mit BIG-IP v12.x-v15.x

F5 Big-IP Controller v1.14.0

Kompatibel mit BIG-IP v12.x-v15.x

Manueller Load-Balancing-Modus Ja Ja Ja Ja
Im Bundle enthaltener Load-Balancer (von Google bereitgestellt) Ja Ja Ja Ja

Speicheroptionen

1,7 1,6 1.5 1.4
vSAN (optional)

vSAN 6.7U3

vSAN 7.0

vSAN 6.7U3 vSAN 6.7U3 vSAN 6.7U3
vSphere-kompatibler Speicher (SAN/DAS/SDS) Ja Ja Ja Ja
CSI-Cloud Storage-Anbieter Siehe Google announces Anthos Ready Storage partner program.

Hinweise

* vSphere Enterprise ist die empfohlene Version.

† NSX-V wird nicht unterstützt.

‡ Die unterstützte Mindestversion von NSX-T ist 2.4.2. Die Unterstützung umfasst ein Knotennetzwerk für die Kommunikation zwischen Knoten. Pod-Netzwerke, Ingress und NSX-T CNI-Integration werden nicht unterstützt. NSX-V wird nicht unterstützt.

# Eine aktuelle Kompatibilitätsmatrix für F5 finden Sie unter Releases und Versionsverwaltung.