Lista de versões do ambiente de execução

O AI Platform Training usa imagens de contêiner, com base na versão do ambiente de execução, para configurar recursos de nuvem que atendam às suas solicitações de treinamento e previsão. Nesta página, você vê a lista das versões de ambiente de execução e os pacotes inclusos. Saiba mais sobre como gerenciar e definir versões do ambiente de execução.

Versões compatíveis do ambiente de execução do AI Platform Training

As seguintes versões são compatíveis no AI Platform Training:

Versão Pacote Liberada em Última atualização Fim da disponibilidade
2.2 TensorFlow 2.2.0
scikit-learn 0.23.1
XGBoost 1.1.1

A versão 2.2 do ambiente de execução é compatível com o TensorFlow 2.2.0 para CPUs e GPUs. As GPUs são compatíveis com treinamento e previsão on-line nessa versão de ambiente de execução. Além disso, ela também aceita TPUs para treinamento.

A versão 2.2 do ambiente de execução não é compatível com a previsão em lote.

O Python 3.7 é a única versão do Python disponível para treinamento e previsão on-line com o ambiente de execução versão 2.2. Não é possível usar o Python 2 com a versão 2.2 do ambiente de execução.

28 de agosto de 2020 28 de agosto de 2020

A partir de 28 de agosto de 2021, não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 28 de agosto de 2022, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

2.1 TensorFlow 2.1.0
scikit-learn 0.22.1
XGBoost 0.90

A versão de ambiente de execução 2.1 é compatível com o TensorFlow 2.1.0 para CPU e GPU. As GPUs são compatíveis com treinamento e previsão on-line nessa versão de ambiente de execução. Além disso, ela também aceita TPUs para treinamento.

O Python 3.7 é a única versão disponível para treinamento e previsão on-line com o ambiente de execução versão 2.1. Não é possível usar o Python 2 com a versão 2.1 do ambiente de execução.

9 de março de 2020 9 de março de 2020

A partir de 9 de março de 2021, não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 9 de março de 2022, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.15 TensorFlow 1.15.0
scikit-learn 0.20.4
XGBoost 0.82

A versão de ambiente de execução 1.15 é compatível com o TensorFlow 1.15.0 para CPU e GPU. As GPUs são compatíveis com treinamento e previsão on-line nessa versão de ambiente de execução. Além disso, ela também aceita TPUs para treinamento.

O Python 3.7 está disponível para treinamento e previsão on-line com a versão 1.15 do ambiente de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

19 de dezembro de 2019 19 de dezembro de 2019

A partir de 30 de setembro de 2021, não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 30 de setembro de 2022, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.14 TensorFlow 1.14.0
scikit-learn 0.20.2
XGBoost 0.81

A versão 1.14 do ambiente de execução é compatível com o TensorFlow 1.14.0 para CPUs e GPUs. As GPUs são compatíveis com treinamento e previsão on-line nessa versão de ambiente de execução. Além disso, ela também aceita TPUs para treinamento.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.14 do ambiente de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

19 de julho de 2019 16 de agosto de 2019

A partir de 19 de julho de 2020, não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 19 de julho de 2021, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.13 TensorFlow 1.13.1
scikit-learn 0.20.2
XGBoost 0.81

A versão de ambiente de execução 1.13 é compatível com o TensorFlow 1.13.1 para CPU e GPU. As GPUs são compatíveis com treinamento e previsão on-line nessa versão de ambiente de execução. Além disso, ela também aceita TPUs para treinamento.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.13 do ambiente de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

6 de março de 2019 16 de agosto de 2019

A partir de 19 de julho de 2020, não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 6 de março de 2021, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.12 TensorFlow 1.12.3
scikit-learn 0.20.0
XGBoost 0.81

A versão 1.12 do ambiente de execução é compatível com o TensorFlow 1.12.3 para CPUs e GPUs. As GPUs são compatíveis com treinamento e previsão on-line nessa versão de ambiente de execução.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.12 do ambiente de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

19 de dezembro de 2018 19 de julho de 2019

A partir de 19 de julho de 2020, não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 19 de dezembro de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.11 TensorFlow 1.11
scikit-learn 0.19.2
XGBoost 0.80

A versão 1.11 do ambiente de execução é compatível com o TensorFlow 1.11.0 para CPUs e GPUs. As GPUs são compatíveis com treinamento e previsão on-line nessa versão de ambiente de execução.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.11 do ambiente de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

19 de dezembro de 2018

A partir de 19 de julho de 2020, não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 19 de dezembro de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.10 TensorFlow 1.10
scikit-learn 0.19.2
XGBoost 0.72.1

A versão 1.10 do ambiente de execução é compatível com o TensorFlow 1.10.0 para CPU e GPU. As GPUs não são permitidas na previsão on-line.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.10 do ambiente de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

31 de agosto de 2018 19 de dezembro de 2018

A partir de (data não definida), não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 31 de agosto de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.9 TensorFlow 1.9
scikit-learn 0.19.1
XGBoost 0.72.1

A versão 1.9 do ambiente de execução é compatível com o TensorFlow 1.9.0 para CPU e GPU. As GPUs não são permitidas na previsão on-line.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.9 do ambiente de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

27 de junho de 2018 19 de dezembro de 2018

A partir de 16 de março de 2020, não será mais possível criar jobs de treinamento que usam essa versão de ambiente de execução.

A partir de (data não definida), não será mais possível criar jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 27 de junho de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.8 TensorFlow 1.8
scikit-learn 0.19.1
XGBoost 0.71

A versão 1.8 do ambiente de execução é compatível com o TensorFlow 1.8.0 para CPU e GPU. As GPUs não são permitidas na previsão on-line.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.8 do tempo de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

Os pacotes gcloud e google-cloud-logging foram substituídos pelo google-cloud, que contém os dois que foram removidos.

8 de maio de 2018 19 de dezembro de 2018

A partir de 16 de março de 2020, não será mais possível criar jobs de treinamento que usam essa versão de ambiente de execução.

A partir de (data não definida), não será mais possível criar jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 8 de maio de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.7 TensorFlow 1.7
scikit-learn 0.19.1
XGBoost 0.7.post3

A versão 1.7 do ambiente de execução é compatível com o TensorFlow 1.7.0 para CPU e GPU.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.7 do tempo de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

26 de abril de 2018 19 de dezembro de 2018

A partir de 16 de março de 2020, não será mais possível criar jobs de treinamento que usam essa versão de ambiente de execução.

A partir de (data não definida), não será mais possível criar jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 26 de abril de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.6 TensorFlow 1.6
scikit-learn 0.19.1
XGBoost 0.7.post3

A versão 1.6 do ambiente de execução é compatível com o TensorFlow 1.6.0 para CPU e GPU.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.6 do tempo de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

20 de março de 2018 19 de dezembro de 2018

A partir de 16 de março de 2020, não será mais possível criar jobs de treinamento que usam essa versão de ambiente de execução.

A partir de (data não definida), não será mais possível criar jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 13 de abril de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.5 TensorFlow 1.5
scikit-learn 0.19.1
XGBoost 0.7.post3

A versão 1.5 do ambiente de execução é compatível com o TensorFlow 1.5.0 para CPU e GPU.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.5 do tempo de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

13 de março de 2018 19 de dezembro de 2018

A partir de 16 de março de 2020, não será mais possível criar jobs de treinamento que usam essa versão de ambiente de execução.

A partir de (data não definida), não será mais possível criar jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 13 de abril de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.4 TensorFlow 1.4.0 e 1.4.1
scikit-learn 0.18.1
XGBoost 0.6a2

A versão 1.4 do ambiente de execução usa o TensorFlow 1.4.0 para previsão on-line e o 1.4.1 para treinamento e previsão em lote.

O Python 3.5 está disponível para treinamento e previsão on-line com a versão 1.4 do tempo de execução. Os pacotes Ubuntu para Python 3 (indicados em negrito) são instalados durante a execução do Python 3.

A versão mais antiga de ambiente de execução do AI Platform Training compatível com scikit-learn e XGBoost é a versão 1.4.

11 de dezembro de 2017 19 de dezembro de 2018

A partir de 16 de março de 2020, não será mais possível criar jobs de treinamento que usam essa versão de ambiente de execução.

A partir de (data não definida), não será mais possível criar jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 13 de abril de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.2 TensorFlow 1.2.0

A versão de tempo de execução 1.2 usa uma imagem de base do Ubuntu 16.04 OS em vez da versão Debian Jessie usada pelo 1.0.

27 de junho de 2017

A partir de 16 de março de 2020, não será mais possível criar jobs de treinamento que usam essa versão de ambiente de execução.

A partir de (data não definida), não será mais possível criar jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 13 de abril de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

1.0 TensorFlow 1.0.1

Esta é a versão de ambiente de execução padrão do AI Platform Training atualmente compatível com a API AI Platform Training and Prediction v1.

8 de março de 2017

A partir de (data não definida), não será mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam essa versão de ambiente de execução.

Em 13 de abril de 2020, o AI Platform Prediction excluirá todas as versões de modelo que usam essa versão de ambiente de execução.

Política de compatibilidade com versões mais antigas do ambiente de execução

O AI Platform Training e o AI Platform Prediction são compatíveis com cada versão de ambiente de execução por um ano após a data de lançamento.

A compatibilidade com cada versão de ambiente de execução é alterada de acordo com a programação a seguir:

  • A partir da data de lançamento: é possível criar jobs de treinamento, jobs de previsão em lote e versões de modelo que usam a versão de ambiente de execução.

  • A partir de 12 meses após a data de lançamento: não é mais possível criar jobs de treinamento, jobs de previsão em lote ou versões de modelo que usam a versão de ambiente de execução.

    As versões atuais do modelo que foram implantadas no AI Platform Prediction continuam funcionando.

  • 24 meses após a data de lançamento: o AI Platform Prediction exclui automaticamente todas as versões de modelo que usam a versão de ambiente de execução.

Uma versão modificada dessa política está sendo aplicada retroativamente, em várias etapas, às versões do ambiente de execução 1.13 e anteriores. Consulte este documento para saber a disponibilidade atual de cada versão de ambiente de execução.

Compatibilidade com GPUs

As máquinas habilitadas para GPU (em inglês) vêm com o tensorflow-gpu (em inglês) pré-instalado, o pacote em Python do TensorFlow com suporte a GPU.

Outras máquinas vêm com o pacote tensorflow (em inglês) normal pré-instalado.

Compatibilidade com Cloud TPU

As versões de ambiente de execução 1.13, 1.14, 1.15, 2.1 e 2.2 do AI Platform Training estão disponíveis para treinar seus modelos no Cloud TPU. Veja como solicitar a cota do Cloud TPU e usar as TPUs para treinar seu modelo.

A seguir